Primevox Communications - Intermittent Voice Quality Issues – Incident details

Intermittent Voice Quality Issues

Resolved
Degraded performance
Started 9 months agoLasted about 6 hours

Affected

Voice Services

Degraded performance from 1:37 PM to 7:38 PM

Outbound Calling

Degraded performance from 1:37 PM to 7:38 PM

Inbound Calling

Degraded performance from 1:37 PM to 7:38 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    A fix has been implemented and we are currently monitoring the situation.

  • Identified
    Identified

    We have identified the internet provider responsible for the congestion and are actively implementing measures to reroute our voice traffic around this provider.

  • Investigating
    Investigating

    There is a significant amount of internet congestion occurring between the East and West coasts, which may cause some customers to experience call quality issues.

    We have reported this to our upstream fiber providers and a solution is being implemented.