Resolved
Intermittent Voice Quality Issues

Started
July 28, 2023 at 4:09 PM
Status
Resolved after 38 minutes

Impact

Degraded performance
Affected
Voice Services
Inbound Calling
Outbound Calling
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Due to some internet congestion along the East Coast, there may be intermittent voice quality issues for some customers.

    All of our upstream fiber carriers have been notified of the issue, and are working on a resolution.