Cloud Softphone for Android: Outbound Calling Issues

Resolved
Operational
Started 3 months ago Lasted 16 days

Affected

Voice Services
Outbound Calling
Updates
  • Resolved
    Resolved

    This incident has been resolved. Updating the app from Google Play will fix it.

  • Identified
    Identified

    After the recent release of Cloud Softphone's version 6.2.3 update on the Google Play Store, Android users have reported that they are unable to make outbound calls. Our development team identified that this version is causing communication issues with encrypted servers, such as Primevox's. Fortunately, Apple and desktop users (Mac/Windows) are unaffected.

    We've reported the issue to Acrobits, the developer of Cloud Softphone, and updates are on the way. For now, we kindly ask Android users to avoid updating the app and recommend disabling automatic app updates until a fix is implemented.