Intermittent Voice Quality Issues

Resolved
Degraded performance
Started 8 months ago Lasted about 23 hours

Affected

Voice Services
Outbound Calling
Inbound Calling
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Due to some internet congestion between the West and East coasts, there may be occasional issues with call quality for a handful of customers.

    The fiber providers involved in the congestion have been notified and are working on a fix now.